Taking timestamped notes with Drafts and Castro

This is going to get a little nerdy, but if you need to take notes on audio on your phone, it might be useful.

Sorry, this is iPhone/iPad only.

What you need

  • Castro - podcast player app
  • Drafts - note taking app
  • Shortcuts - automation app, typically pre-installed by Apple

What this does

  • control playback from your notes taking app (play/pause, rewind, skip ahead)
  • insert current timestamp in note
  • export timestamps and notes as named markers to Reaper or Hindenburg


  1. On your phone, click Get Shortcut here: RoutineHub • Drafts✖️Castro

  2. Install this: Castro | Drafts Directory

  3. Open Drafts and click either (or both) marked buttons to change the set of available actions to the Castro actions

  4. You should now see these quite self-explanatory buttons

Pro tip: you can adjust the amount of seconds for the rewind and skip ahead buttons by long-clicking them, select edit, and change the value in the Define Template Tag step.


The timecode buttons insert either a simple timestamp or one that is linked to the specific time in the episode.

The export buttons save the timestamps and the note that follow them to a file that can be imported as Reaper or Hindenburg markers. (The linked timestamps get converted to simple timestamps in the exported file)

In either Reaper or Hindenburg right-click in the marker manager to import the file.

Another pro tip: If you’re wondering how to play your non-public work-in-progress with Castro, check out its Sideloading feature.

1 Like

Hi Thomas,

This is one cool tool. :sunglasses: It doesn’t work on my iPhone though (iPhone 13 Pro, iOS 15.4).

Always throws an error, when I want to insert a timestamp.

Script Error: SyntaxError: JSON Parse error:
Unexpected EOF
Line number: 1, Column 24

Do you have any idea on what the reason could be?

Thanks for the report. I just pushed an update. Can you update your Drafts action group and check if this fixes it?

Argh, I’m getting the same error again. :frowning:

Sorry, something went wrong with yesterday’s update. Fixed it now.